Dummy 2 not rising error

Powder and inkjet printing
Post Reply
logicone
Posts: 4
Joined: Fri Jan 06, 2023 11:47 am

Dummy 2 not rising error

Post by logicone »

When I run the Inkjet Commander application, I'm greeted with a perplexing 'Dummy 2 not rising' error. Additionally, the test head's reading is puzzling, showing 50/300, which is far from expected. For context, I'm utilizing a B3F38A Black cartridge in this setup.
Standalone controller Version 4.02
User avatar
dragonator
Site Admin
Posts: 595
Joined: Fri Aug 14, 2015 4:48 pm
Location: The Nethelands
Contact:

Re: Dummy 2 not rising error

Post by dragonator »

Hello,

I also saw your mail with this question. I will answer it here so the potential fix may be visible to other people.

Dummy 2 is one of the two resistors used to test the test circuitry. Dymmy 1 is for testing without a printhead installed, Dummy 2 is used for testing with a printhead installed. The error Dummy 2 not rising means that for some reason the dummy 2 resistor (R20) is not testing properly. Lets start with the obvious questions, the 30 ohm resistor is installed in R20 and the TLC59213 (IC4) has all pins properly installed?

You can power up a controller without a printhead to see if dummy 1 does work. This help narrow down the issue a bit. One there is an error, turn of the controller and back on. Errors linger and a power cycle clears them.

50/300 is too little for a properly connected printhead. Either a lot of chips are not well connected, or more likely, the printhead is not properly aligned with the connector. Having just a few pads not make good contact costs a lot of nozzles.
logicone
Posts: 4
Joined: Fri Jan 06, 2023 11:47 am

Re: Dummy 2 not rising error

Post by logicone »

Hello

Yes, that's the issue thanks : the IC4 pin is slightly misaligned. The 300/300 nozzle is currently displaying a temperature of around 40-50°C. I am able to eject the ink while applying preheat, but I am unable to print when sending the image. However, I am able to view the data in the terminal of the ink jet commander .
User avatar
dragonator
Site Admin
Posts: 595
Joined: Fri Aug 14, 2015 4:48 pm
Location: The Nethelands
Contact:

Re: Dummy 2 not rising error

Post by dragonator »

Just sending an image won't make it print. The system is designed around having an encoder to print (it has it's roots in Oasis). It requires a position of the printhead to print. What is easiest to do is set the printhead in virtual velocity mode. Here it will pretend to have a movement at a certain speed when the controller is triggered: https://ytec3d.com/inkjet-commander-manual/

To do this, you should do:
  • Set the print mode to virtual velocity
  • Set a virtual speed (10mm/s should be good for testing)
  • Enable virtual motion
  • Set the trigger position to 0mm
  • Load and convert an image in the software
  • Send an image to the controller at position 10mm or more (not 0, this gives issues)
  • Press the "trigger" button to start the movement.
You should now see the position move, and the buffer read left go down once the position reaches 10mm. This means that the printhead tried printing.
logicone
Posts: 4
Joined: Fri Jan 06, 2023 11:47 am

Re: Dummy 2 not rising error

Post by logicone »

Thanks for your prompt response. While I did observe that the virtual buffer read left decreases as you mentioned, I only see a small purge. I've noticed that when I apply preheat, it purges the ink out of the cartridge quite quickly, whereas when I apply preheat, it ejects very little. I'll share the photos of that
prime
prime
prime.jpeg (47.44 KiB) Viewed 240 times
pre-heat
pre-heat
pre-heat.jpeg (207.71 KiB) Viewed 240 times
I will share photos of this.
Attachments
image with virtual trigger
image with virtual trigger
image with virtual trigger.jpeg (114.15 KiB) Viewed 240 times
User avatar
dragonator
Site Admin
Posts: 595
Joined: Fri Aug 14, 2015 4:48 pm
Location: The Nethelands
Contact:

Re: Dummy 2 not rising error

Post by dragonator »

The prime line should be 2 solid lines. The fact they aren't tells me nozzles in the missing row are clogged.

Preheat should not be ejecting ink. Only purge should really eject ink.

The image usually does not print with a lot of ink. It depends on how you set the printhead (DPI and density determine how dense the image is printed). It depends on the size of your image. Normal images, each pixel is printed with a single drop of ink, so a 300x300 pixel image prints at most with 300x300 pixels at 600DPI.
logicone
Posts: 4
Joined: Fri Jan 06, 2023 11:47 am

Re: Dummy 2 not rising error

Post by logicone »

Once again, dummy1 is not rising. This time there is no misalignment, and it was working fine yesterday as well. Should I replace IC4
User avatar
dragonator
Site Admin
Posts: 595
Joined: Fri Aug 14, 2015 4:48 pm
Location: The Nethelands
Contact:

Re: Dummy 2 not rising error

Post by dragonator »

Is it dummy 1, or is it dummy 2. It does make quite a difference which one is not working.

If the head does test 300/300 it is an ignorable problem. The self testing is a bit finicky and has false negatives. The controller will work despite warnings and errors.
Post Reply